Symptoms
Cannot upload large file using Backup Manager or File Manager:
HTTP Error 404.13 - Not Found
The request filtering module is configured to deny a request that exceeds the request content length.
Cause
Content-Length header of the request is larger than the value specified for this header in
property in
maxAllowedContentLength
.
ApplicationHost.config
By default, maxAllowedContentLength
value in Plesk is 30000000.
Resolution
Note: if you don’t have administrative access to Plesk server via RDP, contact your hosting provider regarding the issue
- Login to Plesk server via RDP
- IncreaseÂ
maxAllowedContentLength
 value:C:> %windir%system32inetsrvappcmd set config “PleskControlPanel/” -section:requestFiltering -requestLimits.maxAllowedContentLength:4294967295
maxAllowedContentLength
 will be set to 4GB. This is the maximum file size which can be uploaded  through IIS.Â
For files more than 4GB
Upload them using the other service (for example, FTP).
Local backup files can be imported to Plesk backup repository like this:
C:> “%plesk_bin%pmm-ras.exe” –import-file-as-dump –dump-file-specification=”C:backup.file”