Symptoms
Unable to create or migrate subscription in Plesk. The following error is shown in Plesk UI:
PLESK_ERROR: Error: System user update is failed: Unable to create system user: Unable to execute usermng: A member could not be added to or removed from the local group because the member does not exist. (Error code 1387) at Unable to add the member (johndoe) to the group (psacln) at (UserManagement::LocalGroup::addMember line 77) at addMember(psacln, johndoe)(UserManagement::LocalGroup::addMember line 80) at execute console command –add(vconsoleapp::start line 93) at execute “C:Program Files (x86)Pleskadminbinusermng” –add “–name=johndoe” “–password=*” “–home=D:/vhosts/example.com”(vconsoleapp::run line 110) (Error code 1)
OR
PLESK_ERROR: Unable to create system user account: A member could not be added to or removed from the local group because the member does not exist. (Error code 1387) at Unable to add the member (johndoe) to the group (Parallels Panel users)
Username of system user (johndoe) specified for new subscription is equal to “Computer name” at Control Panel > System and Security > System.
Cause
Plesk bug PPPM-9949 that will be fixed in further Plesk updates.
Resolution
Change system user name for the subscription (for migration on the source server):
1. Log in to Plesk;
2. Go to Subscriptions > example.com > Web Hosting Access;
3. Change system user name in the Username field. It should be differs from “Computer name”.
OR
Rename Computer Name that is displayed in the Control Panel > System and Security > System (for migration on the destination server).