Symptoms
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SMTP port 25 is closed (not listening) on a Windows Server with MailEnable mail server. It is not possible to telnet to this port:
C:> telnet localhost 25
Connecting To localhost…Could not open connection to the host, on port 25: Connect faile -
Emails are not delivered from external mail services (Gmail, Outlook) to a Plesk mail server without any errors in MailEnable logfiles.
Cause
Custom SMTP port is specified in SMTP settings of MailEnable Management console.
Resolution
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Connect to a Plesk server via RDP.
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Start MailEnable Management console at Windows Start > All Programs > MailEnable.
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In MailEnable Management console, expand Servers > localhost > Services and Connectors > right-click on SMTP and open its Properties.
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In SMTP properties window, switch to the Inbound tab > click Settings in the Port Settings section > set the setting SMTP service listens on port to 25. Apply the changes on both windows.
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In MailEnable Management console, expand System > Services Status > click on MailEnable SMTP Connector > Restart on the right pane.