Skip to main content

Plesk now supports PHP 7.1.x

We’re pleased to announce that Plesk Onyx now supports the latest PHP version 7.1.1.

The update to PHP 7.1.0 brought developers a bunch of cool new improvements such as Catching multiple exceptions types or Nullable Types. For the full list of new features, head over to the official PHP release announcement.

In version 7.1.1, more bugs were fixed to make the PHP 7.1.x branch even more stable.

Planning to update?

Check your CMS version before updating PHP to 7.1!

Because there are several incompatibilities with the last version of PHP.  If you’re working with the three most used Open Source CMSs, the compatible versions are:

  • WordPress >= 4.7
  • Joomla! >= 3.6.4
  • Drupal >= 8.2.3

Plugins and modules are not all operational on PHP 7.1.0 so if you’re planning to migrate from 7.0 (or an earlier version) to 7.1, proceed with caution. You might want to try making a copy of your sites to try out PHP version 7.1 before taking it live if all goes well.

TIP: If you are using the WordPress Toolkit on Plesk Onyx, you will be able to easily duplicate your website and test the new version on the copy first in the next major version of the toolkit!

Check your version of PHP

On your Plesk control panel, go to Tools & SettingsPHP Settings.

PHP 7.1.1 - Plesk PHP Settings

Install PHP 7.1 in Plesk

Go to Tools & Settings – Updates and UpgradesAdd / Remove components. Select PHP 7.1 and click on the “Continue” button.

Install PHP 7.1 in Plesk

After the installation process, you must activate the new version for your domains. Go to Websites & Domains, select your domain and click on the PHP Settings icon. On the next page, you’ll define the PHP version and other parameters, such as the memory limit or the execution time.

Plesk - Activate PHP version 7.1

Select the new version, set your preferred performance and common settings, and click “Save. If you’ve successfully updated your PHP version, you’ll see 7.1.1 under the PHP Settings icon.

Plesk - PHP version 7.1 activated

Note: As mentioned above, not all applications or plugins support the latest PHP version. If an application or plugin is vital to your website, be prepared to switch back to the last PHP version.

Now go forth and try the newest version of PHP, and enjoy the improved performance and decreased memory usage!

Summary
Article Name
Plesk now supports PHP 7.1.x
Description
We're pleased to announce that Plesk Onyx now supports the latest PHP version 7.1.1. The update to PHP 7.1.0 brings developers a bunch of cool new improvements such as Catching multiple exceptions types or Nullable Types. In version 7.1.1, many bugs were fixed to make the PHP 7.1.x branch even more stable.
Author
Publisher Name
Plesk
Publisher Logo

7 thoughts

  1. Niklas -

    But what’s with the sw-collectd bug? It can’t test the configure files on Debian 8.7

    Reply

    Viktor Vogel -

    Hi Niklas,

    please use the forum (https://talk.plesk.com/) or contact the support team (https://www.plesk.com/support/) directly if you have an issue or found a bug.

    Thanks!

    Reply

  2. Mike B. -

    Hello,

    ionCubeloader for 7.1.x is not included?

    Regards,
    Mike

    Reply

    Viktor Vogel -

    Hello Mike, PHP versions 5.6 and 7.0 are already shipped with the ioncube-loader extension enabled. PHP 7.1 should follow in one of the next updates. I will request this feature from the engineering team!

    Reply

  3. Peter -

    Cool. But we need Domain alias support, many other controlpanels already support this feature 🙁

    Reply

    Peter -

    Domain alias support at LetsEncrypt of course.

    Reply

    Viktor Vogel -

    Hi Peter,

    your topic is not related to this article! See here for a discussion about domain aliases in the Let’s Encrypt extension: https://github.com/plesk/letsencrypt-plesk/issues/28

    Please add your comments there! Thanks.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

156 Shares
Tweet12
Share143
Share
Buffer
Reddit
+11