Symptoms
When accessing Tools & Settings > Outgoing Mail Control page the following error appears:
Error: Unable to execute mailmng-outgoing: no such table: OutgoingMessages at execute console command --get-outgoing-messages-domains-stat(vconsoleapp::start line 100) at execute %plesk_dir%adminbinmailmng.exe --get-outgoing-messages-domains-stat "--stat-time=2016-07-25 08:00"(vconsoleapp::run line 117) (Error code 1)
Cannot create a new mail account under a subscription; the account is created, but without a mailbox:
Error: mailmng-outgoing failed: ERROR:outgoing:mails.domain_id may not be NULL
Outgoing mail does not work for one or several domains: PHP scripts may not work, Roundcube webmail returns the following error:
SMTP Error (250): Authentication failed
Cause
The outgoing mail database is corrupted.
Resolution
For Linux
Connect to the server via SSH;
Rename the database:
# mv /var/lib/plesk/mail/outgoing/data.db{,.bak}
Rebuild it:
For RHEL/CentOS/CloudLinux:
# /usr/lib64/plesk-9.0/remote_mail_restore/mail_outgoing_restore
For Debian/Ubuntu:
# /usr/lib/plesk-9.0/remote_mail_restore/mail_outgoing_restore
If the domain was created in Plesk in the initial attempt, delete it at Domains > select the domain example.com > Remove
Add the domain again
For Windows:
Connect to the server via RDP
Delete or rename the file
%plesk_dir%admindbOutgoingMessages.dbRun the command to rebuild it:
"%plesk_dir%adminbinmailmng.exe" --init-outgoing-messages-storage