Symptoms
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Incoming emails (from @gmail) sent to a Plesk domain (@example.com) are being returned
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Outgoing e-mails are delivered fine (from Plesk server to other servers)
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Mail service is enabled for the domain
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MX record is resolved to another server globally:
# dig mx example.com +short @8.8.8.8
10 mail.example.com.
# dig mail.example.com +short
203.0.112.2or does not resolve at all:
# dig mx example.com +short @8.8.8.8
## dig mail.example.com +short @8.8.8.8
#
Cause
The MX record in the DNS zone of example.com is not set correctly.
Resolution
Click on a section to expand
If the DNS zone of example.com is managed in Plesk:
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Domains > example.com > DNS Settings
Make sure that configured MX record is resolved to the correct IP address and mail server. Contact your domain registrar for assistance.
If the DNS zone of example.com is not managed in Plesk.
Contact the domain name administrator or the domain registrar to perform such change in the DNS zone.
Note: In any case, DNS propagation to Internet may take from 24 to 48 hours.