Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Unable to receive or send e-mails in Plesk hosted on DigitalOcean, IONOS, AWS or Microsoft Azure: port 25: Connection timed out

 
amazon lightsailawsazuredigitaloceanec2

Symptoms

  • Unable to receive and send mails from Plesk hosted on DigitalOcean, IONOS, Amazon Lightsail, AWS EC2 or Microsoft Azure instance.

  • Outgoing mail connections via 25 port are not possible, the following error can be found in /var/log/maillog:

    dsn=4.4.1, status=deferred (connect to alt2.gmail-smtp-in.l.google.com[142.250.4.26]:25: Connection timed out)

  • The following error can be found in %plesk_dir%Mail ServersMail EnableLogging:

    Communications Error: Socket connection to gmail-smtp-in.l.google.com failed (error 10060). The host was either not contactable or it rejected your connection. Socket Family = 2; Host=203.0.113.2; Port=25

  • It is possible to send out an email message locally (to a mailbox in Plesk).

  • The following warning can be seen in Tools & Settings > Mail Server Settings:

    You cannot send emails from Plesk because outbound connections on TCP ports 25 and 587 are blocked. Check the firewall settings or contact your hosting provider. If you are sure that the ports are already open, Plesk can recheck them. Start the recheck

Cause

The SMTP port 25 (default for mail relaying even nowadays) is blocked by a firewall that resides on a level above the server on the side of DigitalOcean, IONOS, Amazon or Azure.

Resolution

  • For AWS instance, submit a request to AWS support to have port 25 unblocked in accordance with Amazon documentation or set up mail relay as shown in our free Udemy course.

    Warning: If you have Amazon Lightsail please explicitly mention in the link above that you need to remove the port block for LightSail, otherwise the AWS team will remove it for EC2 only.

  • For Microsoft Azure, contact support at Subscription Management Problem type: Request to enable Port 25 email flow.

  • For IONOS, SMTP port 25 (outgoing) is blocked on a level above the server for security reasons by default. The only way to unblock it is to contact their support, as explained in the following article:
    Setting Up Email on a Server With Plesk - IONOS Help
  • For DigitalOcean, SMTP port 25 is blocked on a level above the server for security reasons by default. The only way to unblock it is to contact their support, as explained in the following article:
    Why is SMTP blocked? | DigitalOcean Documentation
  • If the Plesk Firewall is used, open mail port under Plesk > Tools & Settings > Firewall.

  • If the system or a third-party firewall is active on the server, make sure that it is not blocking the connection to the 25, 465, 993 and 995 ports.

  • In case of an intermediate firewall, it is required to contact the service provider.

Additional information

Unable to send emails using Plesk local mail server: Connection timed out or connection refused. (#4.4.1)
Which Ports Need To Be Opened for all Plesk Services to Work with a Firewall?

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

Podcast | The Increasing Importance of Hyperscalers with Darian Wilkin

Read More »

All You Need to Know About 360 Monitoring on the DigitalOcean Marketplace

Read More »

How to configure external DNS with DigitalOcean DNS extension on Plesk

Read More »
Knowledge Base

Unable to send emails using Plesk local mail server: Connection timed out or connection refused. (#4.4.1)

Read More »

Email header analysis reports SPF failed for localhost IP on mail sent from Plesk hosted mailbox: SPF Authentication : SPF Failed for IP – 127.0.0.1

Read More »

Unable to issue a Let’s Encrypt certificate for a domain or its mail in Plesk: the DNS challenge used another IP address

Read More »

Let’s Encrypt notification mail: Your certificate (or certificates) for the names listed below will expire in days

Read More »

Hosting Wiki

  • GIT
  • Content Security Policy ( CSP )
  • Server Redundancy
  • QMAIL
  • Sendmail
  • Google Cloud CDN
  • Bare Metal Server
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Linux
  • Hosting Control Panel
  • Plesk
  • Web Server
  • DNS Server
  • Firewall
  • Colocation Hosting
  • Reseller Hosting
  • Cloud Hosting
  • VPS Hosting
  • Dedicated Hosting
  • Shared Hosting
  • Free Hosting
  • Managed Hosting
  • Email Autoresponder
  • Mailing Lists
  • Email Alias
  • Email Virus Protection
  • Email Forwarding
  • Webmail
  • SMTP
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family