Symptoms
-
Let's Encrypt auto-renew task is not working for Plesk or a domain.
-
Plesk log
/var/log/plesk/panel.log
contains following entries with debug being enabled:INFO [extension/letsencrypt] Check if Panel or Mail Server is secured by Let's Encrypt certificate...
INFO [extension/letsencrypt] Panel or Mail Server is not secured by the Let's Encrypt certificate.
Cause
Let's Encrypt extension bug #EXTLETSENC-483 (Cannot auto-renew certificates in Plesk if they were renamed previously) which is planned to be fixed in future product updates.
Let's Encrypt auto-renew feature relies on certificate names and does not recognize certificate names other than Lets Encrypt example.com
on domain level and Lets Encrypt certificate
on server level..
Resolution
Until a fix became available, as a workaround, renew the certificate manually:
Securing Plesk
- Log in to Plesk.
- Renew the certificate manually in Tools & Settings > SSL/TLS Certificates > + Let's Encrypt:
Securing particular domain
- Log in to Plesk.
- Renew this certificate manually from Domains > example.com > SSL/TLS Certificates > Get it free.