-
Unable to send email from the server to certain recipients.
-
The following can be found in
/var/log/maillog
:main postfix/smtp[16855]: connect to mx.example.com:25: Connection timed out
main postfix/smtp[16855]: BE46D121BD6: [email protected], relay=none, delay=150, delays=0.13/0.01/150/0, dsn=4.4.1, status=deferred (connect to mx.example.com:25: Connection timed out) -
Outgoing mail mode is set to Send from the specified IP addresses and IPv4 is set to 203.0.113.2 in Tools & Settings > Mail Server Settings.
-
Emails are successfully sent if Send from domain IP addresses is enabled in Tools & Settings > Mail Server Settings or if QMail is selected in Tools & Settings > Mail Server Settings > Installed mail server.
-
In Tools & Settings > IP Addresses there is a private IP address 192.0.2.2, for which a public IP address 203.0.113.2 is assigned and there is a separate IP address 203.0.113.2.
Cause
Incorrect IP configuration.
Resolution
-
Remove public IP address from the private one in Tools & Settings > IP Addresses > 192.0.2.2
-
Remove incorrectly added public IP address 203.0.113.2 in Tools & Settings > IP Addresses
-
Add public IP address 203.0.113.2 in Tools & Settings > IP Addresses > 192.0.2.2