Plesk

Unable to issue or renew Let’s Encrypt certificate in Plesk when external DNS server is used: Incorrect TXT record

Symptoms

Cause

Local DNS service is stopped in Tools & Settings > Services Management.
If this service is stopped then the TXT record for _acme-challenge will not be generated automatically.

Resolution

  1. Log into Plesk

  2. Start the DNS service in Tools & Settings > Services Management.

  3. Go to Domains > example.com > SSL/TLS Certificates

  4. Click on Reissue certificate.

  5. Once the following image is shown, double check if the TXT record resolves externally. This can be checked via ssh with the command dig TXT _acme-challenge.example.com +short:

  6. If it does not resolve, add the record to the external DNS server, removing other existing acme-challenge records from there.
  7. Get back to Plesk screen and click Reload button