Symptoms
Plesk server is hosted with OVH SAS.
When an email is sent to Outlook or Hotmail recipient addresses, the following error is found in
/var/log/maillog:550 5.7.1 Unfortunately, messages from [203.0.113.2] weren't sent. Please contact your Internet service provider since part of their network is on our block list (S3140).
Recipient addresses from other mail services providers are not affected.
Cause
Recently, UCE Protect has placed over a thousand new ASNs on their blacklist. One of OVH SAS' ASN has been listed on the UCEPROTECTL3 blacklist.
Resolution
Contact OVH to get a new IP that is not blacklisted or set up an External SMTP server in Plesk as per the article How to configure an external SMTP server in Plesk:
- For AWS SES it's required to set up your SES account, get out of the sandbox, get your SMTP credentials and apply the article above.
- For SendGrid it is required to adjust Postfix configuration as per How to configure Postfix on Plesk server to send emails using SendGrid