Symptoms
- The hostname (sent as part of the HELO) of the local mail server (usually Postfix) does not match the hostname of the Plesk server defined in Plesk > Tools & Settings > Server Settings (or is set to localhost.localdomain instead of a real hostname):
# telnet 203.0.113.2 25
...
220 localhost.localdomain ESMTP Postfix - After changing the hostname on the server in Plesk, the system notification emails are still sent from the previously used server hostname.
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The IP address of this Plesk server got blacklisted with one of the following messages:
203.0.113.2 was found to be using the following name as the HELO/EHLO parameter during connections: "localhost.localdomain"
OR
This is the mail system at host localhost.localdomain.
... -
Outgoing emails from this Plesk server are marked as spam or not delivered to Gmail, outlook, Yahoo! Mail, etc.
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Non-delivery reports come from the address [email protected].
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MX Lookup Tool by MxToolbox may show the following problem:
SMTP Reverse DNS Mismatch Reverse | DNS does not contain the hostname
- Mail servers are rejecting connections / marking as spam emails from the Plesk server because it does not have a fully qualified domain name (FQDN). As a result, the server IP address may be blacklisted.
Cause
The hostname is not configured properly either on the side of Plesk or on the side of the used mail server's configuration.
Resolution
-
Go to Tools & Settings > Server Settings and specify a FQDN, then click OK:
Note: Server hostname should be resolved to a Plesk server IP address. If a hostname is unknown, contact your service provider for assistance, or use any domain you own, which points to this server.
- Go to Tools & Settings > Mail Server Settings and make sure the Outgoing mail mode is set to Send from domain IP addresses
Note: More information about the different modes is available in <a href="https://support.plesk.com…