Symptoms
-
Emails from a Plesk server are not sent. The following records appear in
/var/log/mailllog
:connect to aspmx.l.google.com[203.0.113.2]:25: Connection timed out
plesk postfix/smtp[17181]: connect to aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable
plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[203.0.113.2]:25: Connection timed out
plesk postfix/smtp[17181]: connect to alt2.aspmx.l.google.com[2001:db8:f61:a1ff:0:0:0:80]:25: Network is unreachable -
It is possible to connect to a remote host on port 25 using the telnet utility:
# telnet alt2.aspmx.l.google.com 25
...
Trying 74.125.28.26...
Connected to alt2.aspmx.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP c68si1753439pfa.129 - gsmtp
Cause
A private IP address is used for outgoing emails.
Resolution
-
Go to Tools and Settings > Mail Server Settings.
-
Set Outgoing mail mode to some public IP address.