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Knowledge Base

Unable to start BIND DNS server in Plesk for Linux: “zone NS has no address records (A or AAAA)” or “zone has no NS records”

 
2022centoschrootdebiandns

Symptoms

  • When starting the DNS Server (BIND) service at Tools & Settings > Services Management, the operation fails with:

    Unable to start service: Unable to manage service by dnsmng: ('start', 'dns'). Error:

  • When starting the BIND DNS service via SSH, the operation fails with an unclear error:

    # systemctl status named-chroot.service
    ...
    systemd[1]: named-chroot.service: control process exited, code=exited status=1
    systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
    systemd[1]: Unit named-chroot.service entered failed state.
    systemd[1]: named-chroot.service failed

  • The following error messages are reported by the named configuration file syntax checking tool:

    • on CentOS/RHEL-based distributions:

      # /usr/sbin/named-checkconf -t /var/named/chroot -z /etc/named.conf | grep -v "loaded serial"

    • on Debian/Ubuntu-based distributions:

      # /usr/sbin/named-checkconf -t /var/named/run-root -z /etc/named.conf | grep -v "loaded serial"

    named-checkconf: zone example.com/IN: NS 'ns1.example.com' has no address records (A or AAAA)
    named-checkconf: zone example.com/IN: NS 'ns2.example.com' has no address records (A or AAAA)
    named-checkconf: zone example.com/IN: not loaded due to errors.
    named-checkconf: _default/example.com/IN: bad zone


    named-checkconf: zone example.com/IN: has no NS records
    named-checkconf: zone example.com/IN: not loaded due to errors.
    named-checkconf: _default/example.com/IN: bad zone

Cause

Product issue:

  • #PPPM-13468 "BIND no longer fails to start if Plesk has websites with enabled DNS zones but absent NS records."
    Fixed in:

    • Plesk Obsidian 24 May 2022 (Linux)

Resolution

Please consider updating your server:

  • How to install Plesk updates

Workaround

If update is not possible for some reason you may try the following

workaround

  1. Log in to Plesk.

  2. Go to Domains > example.com > Hosting & DNS > DNS Settings and apply one of the following solutions:

    • click Add Record to add the missing NS/A records manually. Once a DNS record is added, click Update on the DNS Settings page to apply the changes.

    • click Reset to Default to restore the original zone configuration.

      Note: To add the missing DNS NS records for multiple/all domains at once, add the DNS NS records at Tools & Settings > DNS Template and click Apply DNS Template Changes.

  3. Go to Tools & Settings > Services Management.

  4. Click the Start_button.png button next to DNS Server (BIND) to start the service.

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