Plesk

 Unable to start Apache on a Plesk server: Unable to find IPv4 address of server.example.com

Symptoms

Cause

There is no IPv4 address specified in the /etc/hosts file for the server name configured in /etc/hostname file.

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > Server Settings.

  3. In the Full hostname field, set the server hostname.

  4. Click OK.

  5. Go to Tools & Settings > Services Management and make sure Web Server (Apache) is started.

 

Command-line instructions

 

  1. Connect to the Plesk server via SSH.

  2. Open the file /etc/hosts in a text editor. In this example, we are using the vi editor:

    # vi /etc/hosts

  3. Add a valid <IPv4 hostname> configuration:, for example:

    203.0.113.2 server.example.com

    • Server hostname can be edited in the file /etc/hostname or can be found with the command hostname.
  4. Reboot the server.

  5. Verify that Apache has been started:

    • on CentOS/RHEL-based distributions:

      # service httpd status

    • on Debian/Ubuntu-based distributions:

      # service apache2 status