Plesk

Unable to send emails or create a mailbox: Error: mailmng-outgoing failed: ERROR:outgoing:mails.domain_id may not be NULL

Symptoms

Cause

Inconsistency in the Plesk database and/or the external SQLite database controlling outgoing mail limits.

Resolution

Note: The solution described in this article requires root access, if it's not available please contact the hosting service provider

  1. Connect to the server via SSH

  2. In case there is any customization in the Mail Server configuration files, back them up:

    For Postfix:

    # cp -rp /etc/postfix{,.old}

    For Qmail:

    # cp -rp /var/qmail/control{,.old}

  3. Back up the Plesk databases:

    # plesk db dump psa apsc > psa_apsc_backup.sql

  4. Repair any Plesk database inconsistency:

    # plesk repair db -y

  5. Repair any mail inconsistencies:

    # plesk repair mail -y

  6. If the issue persists, back up the outgoing mail limits database:

    # mv /var/lib/plesk/mail/outgoing/data.db{,_bk}

  7. Repair outgoing limits configuration:

    On RHEL/CentOS based systems:

    # /usr/lib64/plesk-9.0/remote_mail_restore/mail_outgoing_restore

    On Debian/Ubuntu based systems:

    # /usr/lib/plesk-9.0/remote_mail_restore/mail_outgoing_restore

Exit mobile version