Symptoms
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When sending an email via Roundcube webmail, the operation fails with:
SMTP Error (250): Authentication failed.
SMTP Error (554): Failed to add recipient "[email protected]" (5.7.1 <[email protected]>: Relay access denied)."
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One of the following error messages appears in
/var/log/plesk-roundcube/errors
:SMTP Error: Authentication failure: SMTP server does not support authentication (Code: ) in /usr/share/psa-roundcube/program/lib/Roundcube/rcube.php
SMTP Error: Authentication failure: Invalid response code received from server (Code: 502) in /usr/share/psa-roundcube/program/lib/Roundcube/rcube.php on line 1667
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The following error messages appear in
/var/log/maillog
:postfix/smtpd[104223]: connect from localhost[::1]
postfix/smtpd[104223]: NOQUEUE: reject: RCPT from localhost[::1]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<webmail.example.com>
postfix/smtpd[104223]: disconnect from localhost[::1]
Cause
The Relaying option is set to closed in Plesk at Plesk > Tools & Settings > Mail Server Settings.
With closed relay, the mail server accepts only messages addressed to the users who have mailboxes on this server. The customers will not be able to send any mail through the outgoing SMTP server, therefore, it is not recommended to close the mail relay.
Resolution
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Go to Tools & Settings > Mail Server Settings.
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Switch Relaying option to the authorization is required: SMTP.
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Click OK to apply the changes.