Plesk

Unable to receive emails: 550 5.1.1 Recipient not found

Symptoms

Cause

3rd-party MX records are configured on the registrar side. Plesk cannot manage mailboxes in such cases.

Resolution

Configure DNS settings to pass mail management to Plesk:

  1. Remove the following record in Plesk > Domains > example.com > DNS Settings (If such present):

    example.com MX 0 smtp.europe.secureserver.net.

  2. Create MX record similar to the record below, at Plesk > Domains > example.com > DNS Settings:

  3. Make sure that the same MX records as from step 2 configured on the registrar side. For example, if DNS is managed by GoDaddy, MX records must be modified on the GoDaddy side.