Plesk

Unable to activate or suspend a domain in Plesk: Some fields are empty or contain an improper value. (’email’ = ”)

Cause

DNS zone is not configured for the domain or email address is missing from DNS zone configuration.

Resolution

  1. Connect to the Plesk server via SSH (Linux) or RDP (Windows)

  2. Create Plesk database backup

  3. Log in to Plesk

  4. Restore default DNS settings for the domain at Domains > example.com > DNS Settings > Reset to Default