Plesk

The spam messages are not blocked when the Plesk Email Security extension is installed

Symptoms

Cause

The Plesk Email Security extension is not configured to block the spam messages.

Resolution

Apply one of the solutions below:

For the specific mailbox

  1. Log into Plesk.
  2. Go to Domains > example.com > Mail Accounts.
  3. Press the Settings button in front of the required mailbox:

  4. Switch to Settings for johndoe@example.com tab.
  5. Set Block for the Spam action * option:
  6. Scroll down and press the Save button to apply the changes.

For all mailboxes on the server

  1. Log into Plesk.
  2. Go to Tools & Settings > Plesk Email Security > Server Settings.
  3. Set Block for the Spam action * option:
  4. Scroll down and press the Save button to apply the changes.