Plesk

Plesk Email Security extension blocklist does not work

Symptoms

Cause

This behavior is tied to a known bug for the Plesk Email Security extension with ID #EXTPLESK-4437 Plesk email security blocklist doesn't work. The bug in question will be fixed in future releases of Plesk. You can confirm whether the bug was resolved permanently by looking for the bug ID in the Plesk Change Log.

Resolution

As a temporary workaround, you may block the incoming email senders directly in Postfix by following these steps:

1. Log into your server via SSH

2. Open (or create) the /etc/postfix/sender_access file with your favorite command-line text editor
3. Append sender email ID as necessary by using the following examples:

# ADDRESS PATTERNS         # ACTION
sender@example.com         550 Blacklisted
domain.com                 REJECT
user@                      REJECT

4. Save and close the file

5. Use the postmap command in order to create a database based on the file that was created:

# postmap /etc/postfix/sender_access

6. Open /etc/postfix/main.cf with a command-line text editor and add the following line:

smtpd_recipient_restrictions = check_sender_access hash:/etc/postfix/sender_access

7. Save and close the file

8. Restart Postfix by executing the following command:

# systemctl restart postfix

Additional information

Permanently reject a specific email sender address using postfix - Experiencing Technology

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