Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Mail stuck in queue on Plesk server: delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused

 
amavisddebiandomain nameemailemail security

Symptoms

  • E-Mails are stuck in mail-queue on a Plesk server with installed Plesk Email Security extension

  • The following error messages appear in /var/log/maillog:

    name postfix/error[14531]: 8954F66E14A4: [email protected], relay=none, delay=25755, delays=25754/0.07/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

  • The Amavis service is stopped with one of the following errors:

    # systemctl status amavisd
    (...)
    systemd[1]: Starting Amavis mail content checker...
    name amavisd[1507]: The value of variable $myhostname is "name", but should have been
    name amavisd[1507]: a fully qualified domain name; perhaps uname(3) did not provide such.
    name amavisd[1507]: You must explicitly assign a FQDN of this host to variable $myhostname
    name amavisd[1507]: in amavisd.conf, or fix what uname(3) provides as a host's network name!


    # systemctl status amavis
    (...)
    name amavis[1108]: Starting amavisd: The value of variable $myhostname is "name", but should have been
    name amavis[1108]: a fully qualified domain name; perhaps uname(3) did not provide such.
    name amavis[1108]: You must explicitly assign a FQDN of this host to variable $myhostname
    name amavis[1108]: in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
    name amavis[1108]: network name!
    name amavis[1108]: (failed).

Cause

The server's hostname is not a fully qualified domain name.

Resolution

  1. Log into Plesk

  2. Navigate to Tools & Settings > Server Settings and change Full hostname to temporary one (for example temp.server.example.com)

  3. Press OK

  4. Open Tools & Settings > Server Settings and change Full hostname back to the original fully qualified domain name again and press OK

  5. Connect to the server via SSH

  6. Make sure that "$myhostname" variable inside the /etc/amavisd/amavisd.conf is equal to the hostname set in step 4.
  7. Start amavis service:

    • On RHEL based operating system:

      # service amavisd start

    • On Debian based operating system:

      # service amavis start

Note: Make sure the hostname is not set to a non-fully qualified domain name by a hypervisor in case the problem reappears.

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

Recommended OSs for Plesk

Read More »

Advanced Techniques for Building an Email List

Read More »

How Modern Secure and Self-Hosted Messaging has Become a Cornerstone for Teams Worldwide

Read More »
Knowledge Base

Unable to send mail from Plesk server: deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Read More »

Email header analysis reports SPF failed for localhost IP on mail sent from Plesk hosted mailbox: SPF Authentication : SPF Failed for IP – 127.0.0.1

Read More »

Mail delivery does not work: do not list domain in BOTH mydestination and virtual_mailbox_domains

Read More »

Websites on Plesk server are slow or show error 500 or PHP mail cannot be sent: ap_pass_brigade failed

Read More »

Hosting Wiki

  • Content Security Policy ( CSP )
  • Server Redundancy
  • QMAIL
  • Sendmail
  • Postfix
  • Bare Metal Server
  • Oracle VM Server
  • Citrix Hypervisor
  • Server Virtualization Software
  • Windows Server
  • Linux
  • Domain
  • Plesk
  • Web Server
  • DNS Server
  • SSH
  • Network Bandwidth
  • Email Autoresponder
  • Mailing Lists
  • Email Alias
  • Email Virus Protection
  • Email Forwarding
  • Webmail
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family