Symptoms
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example.com is hosted locally in Plesk, but its mail is handled by an external mail server.
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When sending an email from one of the domains hosted in Plesk to a mailbox of example.com, the email fails to be delivered with one of the following error messages in
/usr/local/psa/var/log/maillog
:550 5.1.1 [email protected]: Recipient address rejected: User unknown in virtual mailbox table; [email protected] [email protected]
example.com postfix-local[23040]: cannot chdir to mailname dir contact: No such file or directory
example.com postfix-local[23040]: Unknown user: [email protected]
ME-E0103: [1076] Local Delivery: Failure - Domain for ([SMTP:[email protected]]) is locally serviced, but recipient is not defined in address map.
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In webmail, the following error message is shown:
Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid
Error: SMTP Server rejected email. Returned:550 sorry, no mailbox here by that name. (#5.7.17)
Error SMTP (500): The following recipient could not be reached "[email protected]" (sorry, no mailbox here by that name. (#5.7.17)).
There was an error sending your message: Message could not be delivered - the address was not found, is unknown, or is not receiving messages.
550 5.1.1 [email protected] ... User unknown (in reply to MAIL FROM command))
Cause
When mail service of a domain is enabled in Plesk, local mail server treats this domain as a local domain and tries to send emails locally.
Resolution
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Go to Domains > example.com > Mail tab > Mail Settings.
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Switch Mail service on this domain to Disabled for incoming mail.
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Apply the changes.