Plesk

Web statistics are not updated automatically in Plesk for Windows but manual web statistics calculation works correctly

Symptoms

Cause

Going to Windows > Task Scheduler, the scheduled task Plesk Scheduler Task - Daily web statistics analyzers run task is misconfigured

Resolution

  1. Connect to the server via RDP

  2. Go to Task Scheduler > Task Scheduler Library and select one of the following use cases:

    Scheduled task doesn't exist

    Start a command prompt as Administrator and run the following command to recreate the scheduled task:

    C:> "%plesk_bin%crontabmng.exe" create-web-stat-executor-task

    Scheduled task is disabled

    Right-click on the scheduled task and press Enable:

    Click Install

    A scheduled task is stuck

    In the case that the scheduled task is stuck with Running status, restart the server to make sure the process is free up properly

    A Scheduled task has an incorrect path to the executable file specified

    Right-click on the scheduled task and press Properties.
    Navigate to Actions and edit the "Add arguments" field so it has a valid path to the "web_statistics_executor.exe":

    Update to path containing web_statistics_executor.exe:
    /c "C:Program Files (x86)Pleskadminbinruntask.exe" "--mail=jdoe@example.com" "--application=C:Program Files (x86)Pleskadminbinweb_statistics_executor.exe" "--parameters=""

  3. To calculate the traffic statistics for all the domains and verify the issue was solved, Right-click on the scheduled task and press Run. Once the scheduled task will finish, log in to Plesk GUI and verify that the Traffic statistics are displayed correctly.

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