Symptoms
- Unable to connect mail client on SMTPS port 465/993 SSL/TLS connection. Mail client displays the error:
Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'my email', Server: '3.4.5.6', Protocol: SMTP, Port: 465, Secure(SSL): Yes, Error Number: 0x800CCC0F
-
Following error message is present in
/usr/local/psa/var/log/maillog
:postfix/smtpd[31990]: warning: TLS library problem: 31990:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1197:SSL alert number 48:
postfix/smtpd[31990]: lost connection after CONNECT from unknown[1.2.3.4]
postfix/smtpd[31990]: disconnect from unknown[1.2.3.4] -
Mail client displays the following error:
Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: 'my email', Server: '3.4.5.6', Protocol: SMTP, Port: 465, Secure(SSL): Yes, Error Number: 0x800CCC0F
Cause
SSL CA certificates bundle is missing or corrupted.
Resolution
-
Install a valid certificate using the article Plesk following the instructions here: How to secure mail server with Let's Encrypt certificate
-
Connect to the server via SSH.
-
Run the following command:
# plesk repair mail
- In case this issue still persists, reinstall
ca-certificates
package.For example, for CentOS 6:
# rpm -Uhv ca-certificates-2010.63-3.el6_1.5.noarch