Symptoms
When sending an email from Plesk to an external server, the email is stuck in the outgoing queue or fails to be sent with the following bounce message:
MailEnable: Message could not be delivered to some recipients.
The following recipient(s) could not be reached:
Recipient: [SMTP:<username>@gmail.com]
Reason: The message could not be delivered because the domain name (gmail.com) does not appear to exist.One of the following messages is logged in
C:Program Files (x86)Mail EnableLoggingSMTPSMTP-Debug-<datetime>.log:ME-E0124: Error (1460): Could not resolve MX list for domain [example.com]
ME-E0042: - SMTP Connection DNS Server could not resolve domain name (example.com) in a timely fashion. Check DNS Server settings.
ME-E0042: [71F2BE266CCF446CA0B9225A0DD2D496.MAI] - SMTP Connection DNS Server could not resolve domain name (example.com) in a timely fashion. Check DNS Server settings.
ME-E0059: [71F2BE266CCF446CA0B9225A0DD2D496.MAI] Message Delivery Failure. Attempt (0): Could not connect to mail server for domain (example.com). The remote mail server could not be contacted at this time. Message has been requeued.The recipient's domain name example.com can be resolved externally. For instance:
C:> nslookup example.com
Address: 203.0.113.2and its MX record can be verified as described in this article.
Cause
Local DNS resolver fails to resolve the domain name of the recipient.
Resolution
Connect to the Plesk server via RDP.
Start MailEnable console at Windows Start > All Programs > MailEnable.
In MailEnable console, expand Servers > localhost > Services and Connectors > right-click on SMTP > Properties.
On the General tab, specify DNS IP addresses in the DNS addresses field. For example, Google DNS
8.8.8.8or4.4.4.4:Click OK to apply the changes.
Restart SMTP server to apply changes: right click on SMTP > Stop > then Start.
Try to send an email again.
If the issue still persists, set up DNS resolver in Windows Networking settings: