Symptoms
- Unable to login to email via IMAP when Dovecot server is used with valid credentials:
Roundcube Connection to storage server failed
- Following errors pop-up in Roundcube webmail from time to time:
Empty startup greeting (localhost:143)
- In
/var/log/maillog
the following error message can be found:dovecot: master: Warning : service(imap-login): process_limit (128) reached, client connections are being dropped
dovecot: imap-login: Error: read(imap) failed: Remote closed connection (destination service { process_limit } reached?) - If Watchdog extension is installed on the server the following error can be found in
:
/var/log/plesk/modules/monit.logmonit: embed_ssl_socket(): Openssl syscall error: Connection reset by peer!
'dovecot' failed, cannot open a connection to INET[localhost:993]
'dovecot' stop: /usr/local/psa/admin/bin/mailmng-service
'dovecot' failed, cannot open a connection to INET[localhost:143]
'dovecot' process is not running
'dovecot' trying to restart 'dovecot' start: /usr/local/psa/admin/bin/mailmng-service
Cause
Dovecot connections limit exhausted: insufficient values for the "process_limit".
Resolution
- Login to Plesk
- Go to Tools & Settings > Mail Server Settings > change the value for Maximum number of connections (IMAP, POP3, IMAP over SSL/TLS, or POP3 over SSL/TLS) to a default one (1024) or higher: