Plesk

Unable to log in webmail with courier_imaps service on Plesk server: 504 Gateway Timeout

Symptoms

Cause

IMAPs connection limit being reached.

In case if Watchdog is installed, it fails to perform a test connection due to IMAPs connection limit being reached.

Resolution

  1. Log into Plesk

  2. Go to Tools & Settings > Mail Server Settings > Maximum number of connections (IMAP, POP3, IMAP over SSL/TLS, or POP3 over SSL/TLS).
    Increase the maximum number of connections, e.g if 40 is set, increase it to 80.

  3. In case if Watchdog is installed, increase time during which Watchdog will be waiting for response from the polled service under Extensions > Watchdog > Courier*> Connection timeout

    Note: increase parameter for all Courier services:
    Courier POP3 Server
    Courier POP3 Server with SSL/TLS support
    Courier IMAP server
    Courier IMAP server with SSL/TLS support