Plesk

The FROM address is replaced by the forwarder email address when the Fix incorrectly set sender for outgoing mail option is enabled

Symptoms

Cause

Product issue:

  • #PPPM-12293 "Sending an email from a mailbox associated with domain A to a mailbox associated with domain B that is hosted in Plesk with “Fix incorrectly set sender for outgoing mail” enabled in “Tools & Settings” > “Mail Server Settings” and forwards mail to a mailbox associated with domain C no longer changes the “From” header as if the email originated from domain B and not domain A."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

Until the bug will be fixed apply the workaround below: 

  1. Log into Plesk.
  2. Go to Tools & Settings > Mail Server Settings.
  3. Disable the Fix incorrectly set sender for outgoing mail option.
  4. Scroll down and press the OK button.
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