Plesk

The “Activate mail service on this domain” button is greyed / grayed out for a Plesk domain

Symptoms

Cause

Plesk database inconsistency in table entries that concern the status of the mail service for this domain.

Resolution

  1. Connect to the server via SSH (Linux) / via RDP (Windows Server).

    Note: On Windows Server, you would also need to start a command prompt as an Administrator.

  2. Create a backup of the Plesk database:

    • Plesk for Linux

      # plesk db dump psa > psa.sql

    • Plesk for Windows

      C:> plesk db dump psa > C:psa.sql

  3. Open Plesk database in MySQL:

    # plesk db

  4. Acquire the ID of the domain with disabled mail service by executing this query:

    Note: In the example below, the domain name example.com has an ID 167

    mysql> SELECT id FROM DomainServices WHERE type='mail' AND dom_id=(SELECT id FROM domains WHERE name='example.com');
    +----+
    | id  |
    +----+
    | 167 |
    +----+

  5. Change mail service status using the id number obtained in the previous step:

    mysql> UPDATE DomainServices set status=0 WHERE type='mail' AND id=167;
    Query OK, 1 row affected (0.00 sec)

  6. Disable and enable the mail service for the subscription at Plesk > Subscriptions > example.com > Mail > Mail Settings in order to make sure it is now working as expected.

Additional information

What is Sendmail? Hosting Wikipedia

 

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