Symptoms
Mails are not received in Plesk with Plesk Premium Antivirus (DrWeb), the emails are bounced with the following message:
Dear User,
A message with the following attributes was not delivered because it contains an object which cannot be checked by antivirus.
Relaying such messages is blocked by administrator.
...
Detailed report:
The filter fails to pass object to the DrWEB daemon
Cause
Another service is using port 3000 which should be used by Plesk Premium Antivirus (DrWeb):
# netstat -putan | egrep :3000|:3030 | grep LISTEN
tcp 0 0 127.0.0.1:3030 0.0.0.0:* LISTEN 1441/grafana-server
tcp 0 0 127.0.0.1:3000 0.0.0.0:* LISTEN 1644/grafana-server
The port 3000 is busy by Grafana-server (or other service such as BitNinja) handled by a 3rd party service manager (GitLab):
# ps awufx
…
root 1610 0.0 0.0 4044 664 ? Ss 10:12 0:00 _ runsv grafana
root 1638 0.0 0.0 4188 704 ? S 10:12 0:00 | _ svlogd -tt /var/log/gitlab/grafana
gitlab-+ 1644 0.0 0.0 1359880 40608 ? Ssl 14:27 0:00 | _ /opt/gitlab/embedded/bin/grafana-server -config /var/opt/gitlab/grafana/grafana.ini
-
The Grafana configuration file installed by Plesk binds correctly on the port 3030:
# grep http_port /etc/grafana/grafana.ini
http_port = 3030
Resolution
-
Connect to the server via SSH
-
Stop the 3rd party service to free up the port 3000:
# systemctl stop grafana-server
-
Restart DrWeb daemon service:
# systemctl restart drwebd