Plesk

Mail queue in Plesk contains deferred emails: Host or domain name not found

Symptoms

Cause

The server is configured to use a DNS resolver that cannot be reached or cannot resolve DNS names. Alternatively, it may be possible that there are no DNS servers configured in /etc/resolv.conf.

Resolution

1. Connect to the server via SSH

2. Add proper resolver to /etc/resolv.conf. For example:

# cat /etc/resolv.conf
nameserver 8.8.8.8

3. Restart postfix:

# systemctl restart postfix

Note: If in /etc/resolv.conf there are more nameservers, please set it on top of the nameservers list. Nameservers list order matters.
Note:  Sometimes, In Debian/Ubuntu OSes  /etc/resolv.confcan be managed only by system utilities and manual adjustments may not work. In this scenario, it's necessary to do some extra steps as mentioned here

Warning: Make sure that the nameservers configured in the server are reachable from the server network

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