Symptoms
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Outgoing mail control is enabled under Plesk > Tools & Settings > Mail Server Settings > Switch on limitations on outgoing email messages
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Changes to any limit of outgoing mail control on the Service plan level and applying it under Plesk > Service Plans > service_plan_name > Mail tab makes the synchronization to Subscriptions that use the plan fail, but the Subscription still shows up as being in sync with its Service plan
- Custom values for outgoing messages set at Plesk > Service Plans > service_plan_name > Mail tab do not apply for the Subscription after the synchronization fails
Cause
Outgoing mail limits are not changed along with Service plan values when the Ability to change mail settings permission is enabled at Service Plans > Service Plan Name > Permissions.
The Ability to change mail settings permission allows the separate Subscriptions to change their own mail settings.
This behavior is currently expected by design, however our development team is considering improvements that would make this more clear. The improvement progress tracked as a bug with ID #PPPM-8936.
You may track the progress in the Change Log for Plesk Obsidian.
Resolution
For the moment, in order to change outgoing mail control values on Subscriptions, you need to apply one of the following solutions:
Disable the Ability to change mail settings permission at Service Plans > Service_Plan_Name > Permissions (that way values specified in Service plan will be applied to Subscriptions that are using the plan).
Change the value for an affected domain manually at the specific mailbox settings by going to Domains > example.com > Mail > Mail Accounts > [email protected]
Adjust the outgoing mail control value for the desired Subscription as necessary at Tools & Settings > Outgoing Mail Control > Subscriptions > example.com and then press Change Limit