Plesk

Domains show Plesk default page or mail services misbehave: web service cannot operate: the IP address list with ID 101 is empty

Symptoms

Cause

Inconsistency in the Plesk database (psa) after manual IP removal that was not done via the Plesk graphical interface or the Plesk CLI commands.

Resolution

  1. Connect to the server via SSH

  2. Create Plesk database backup

  3. Find the affecting domain using ID from error message:

    # plesk db "SELECT ipCollectionId, name FROM DomainServices JOIN domains ON dom_id = domains.id WHERE ipCollectionId = 101"
    +-----------------+----------------+
    | ipCollectionId | name |
    +-----------------+----------------+
    | 101 | example.com |
    +-----------------+----------------+

  4. Find the IP address that should be used for the domain:

    # grep listen /var/www/vhosts/system/example.com/conf/nginx.conf
    listen 203.0.113.2:443 ssl http2;
    listen 203.0.113.2:80;

  5. Find the ID of the IP address to be used:

    # plesk db "SELECT id, ip_address FROM IP_Addresses WHERE ip_address = '203.0.113.2'"
    +-----+--------------+
    | id | ip_address |
    +-------+------------+
    | 1 | 203.0.113.2 |
    +-----+--------------+

  6. Insert a record for the IP address from step 3 using ID from the error message and step 5.:

    # plesk db "insert into IpAddressesCollections values(101, 1)"

  7. Once all of the inconsistencies are resolved, initiate the reread operation for IP addresses assigned to your Plesk server by executing the following command:

    # plesk bin ipmanage --reread

  8. Repair broken web configuration files:

    # plesk repair web -y

  9. Repair broken mail configuration files:

    # plesk repair mail -y

Additional information

Unable to remove an IP address via Plesk: IP address 203.0.113.2 cannot be removed because it is used by DNS zone of one or more domains

IP Addresses Management | Plesk Obsidian documentation

ipmanage: IP Addresses | Plesk Obsidian documentation

Exit mobile version