Plesk

Unable to start BIND DNS server in Plesk for Linux: “zone NS has no address records (A or AAAA)” or “zone has no NS records”

Symptoms

Cause

Product issue:

  • #PPPM-13468 "BIND no longer fails to start if Plesk has websites with enabled DNS zones but absent NS records."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

  1. Log in to Plesk.

  2. Go to Domains > example.com > Hosting & DNS > DNS Settings and apply one of the following solutions:

    • click Add Record to add the missing NS/A records manually. Once a DNS record is added, click Update on the DNS Settings page to apply the changes.

    • click Reset to Default to restore the original zone configuration.

      Note: To add the missing DNS NS records for multiple/all domains at once, add the DNS NS records at Tools & Settings > DNS Template and click Apply DNS Template Changes.

  3. Go to Tools & Settings > Services Management.

  4. Click the button next to DNS Server (BIND) to start the service.