Plesk

The database list in Plesk is displayed incorrectly when logged in as customer

Symptoms

Pressing the Database button on the left panel when logged in as the customer displays an incorrect URL - https://hostname:8443/smb/database instead of https://hostname:8443/smb/database/list

As a result, the database list is empty.

Cause

Product issue:

  • #PPPM-13599 "Additional users restricted to accessing only one specific subscription can no longer see the list of all subscriptions of the customer."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

As a workaround:

1. Connect to the server via SSH

2. Open the /usr/local/psa/admin/conf/panel.ini file in any text editor (for example, vi) - it will be created automatically in case it is missing:

# vi /usr/local/psa/admin/conf/panel.ini

3.  Add the following block to the bottom of the file:

[navigation]
switchToAllWebspacesAfterCreation = false