Symptoms
Cannot access Plesk from WHMCS via API as a customer or change password:
Error code: 1013. Error message: Customer with external id 'whmcs_plesk_XX' is not found in panel.
Error code: 1013. Error message: Customer with email '[email protected]' is not found in panel. Please contact your service provider.
Cause
The external_id
entry is missing in psa.clients
MySQL table.
Resolution
Note: if the issue appears on WHMCS integrated with Plesk Multi Server, this database update should be done on the management node side.
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Log in to the server via SSH
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Create a backup of psa database:
# plesk db dump > psa.current.sql
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Access Plesk database from command line:
# plesk db
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Update the following value:
update clients set external_id='…