Plesk

Empty inbox is shown in webmail on a Plesk server: Cached message size larger than expected

Symptoms

Cause

Mailbox cache file mentioned in the error is broken or corrupted.

Resolution

  1. Connect to the server via SSH.

Plain mail

  1. Move Dovecot cache files from the error message to re-create cache:

    # mv /var/qmail/mailnames/example.com/username/Maildir/dovecot* /tmp/
    # mv /var/qmail/mailnames/example.com/username/Maildir/cur/1520269963.M402118P28216V0000000000000802I00000000001840FA.CL0016UC-SG1.EXAMPLE.COM,S=1448:2,S /tmp/

    Cache will be re-created automatically.

  2. Restart dovecot service:

    # service dovecot restart

GZipped Mail Resolution

  1. Edit file /etc/dovecot/conf.d/99-zlib-support.conf and add the following content:

    mail_plugins = $mail_plugins zlib

    protocol imap {
    mail_plugins = $mail_plugins imap_quota zlib
    }

  2. Restart dovecot service:

    # service dovecot restart