Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

WordPress instances marked as broken in: Plesk WP Toolkit has found WordPress files at the following path

 
applications extensionsbackupdatabasednsdomains

Symptoms

  • The WordPress Instance marked as BROKEN in Plesk > Domains > example.com > WordPress the following message shown (WordPress site however is working correctly):

    WP Toolkit has found WordPress files at the following path: /var/www/vhosts/example.com/httpdocs/wordpress
    However, it does not seem that this WordPress website is working. Try restoring the website from a backup or cleaning up the redundant files.

  • The following error can be found in /var/log/plesk/panel.log:

    Failed to change directory to /var/www/vhosts/example.com/httpdocs/wordpress: No such file or directory

  • The Document root for the WordPress installation on a certain domain was adjusted recently
  • A domain was converted to a separate Subscription in Plesk recently

Cause

The WordPress content tied to this domain was moved manually to a different directory, due to which the WP Toolkit database has not been updated with information about this change. The directory mentioned in the error message is actually missing on the server or no files can be found inside:

# ll /var/www/vhosts/example.com/httpdocs/wordpress:
ls: cannot access /var/www/vhosts/example.com/httpdocs/wordpress:: No such file or directory

Resolution

Note: WP Toolkit entries for all existing WordPress installations are not connected to the websites themselves, due to which detaching a WordPress installation from the WP Toolkit does not alter any files or databases for the related WP installation, but only alters records tied to this installation in the WP Toolkit database.

1. Log into Plesk

2. Go to Domains > example.com > WP Toolkit
3. Press on the three vertical dots on the top right of this domain entry in the WP Toolkit

4. Press Detach

Afterwards, in order to attach the same WP installation back to the WP Toolkit in Plesk, so that it can acquire the updated Document root information, you need to do the following:

Note: You must also make sure that the Document root for the domain is configured properly in Plesk > Domains > example.com > Hosting & DNS > Hosting

1. Log into Plesk
2. Go to WordPress
3. Click Scan

In case Plesk for Linux is used

  1. Connect to the Plesk server via SSH.
  2. Create a dump of the Plesk database 

  3. Create backup of WP Toolkit database:

    # cp -p /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3{,.backup}

  4. Remove leftovers of affected instance from WP Toolkit database:

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3
    # sqlite> .headers on
    # sqlite> select instanceId from InstancesDomains where domainId=123;
    instanceId
    567
    # sqlite> DELETE FROM InstanceProperties WHERE instanceId=567;
    # sqlite> DELETE FROM InstancesDomains WHERE instanceId=567;
    # sqlite> DELETE FROM Instances where id=567;
    # sqlite> .quit

In case Plesk for Windows is used

  1. Connect to the server via RDP
  2. Create a dump of the Plesk database 

  3. Download sqlite3.exe from this link into C:temp
  4. Create copy of WP Toolkit database, located in %plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3

  5. Open cmd.exe as Administrator and remove…
Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

DNS_PROBE_FINISHED_NXDOMAIN: What Is It And How To Fix The Problem

Read More »

Exploring Plesk’s Added Value Solutions So Far in 2023

Read More »

Unveiling Sitejet Builder: The Perfect Match for Your Effortless Website Creation Needs

Read More »
Knowledge Base

WP Toolkit Cloning hangs or stops after 60 seconds on a Plesk server

Read More »

Duplicate entries in Plesk WP Toolkit: nginx: [emerg] duplicate location “/fake-hotlink-stub”

Read More »

Can’t install plugin via WP Toolkit: destination folder already exists

Read More »

Unable to log in to a WordPress dashboard via Plesk: The “Log in” button is missing in WP Toolkit

Read More »

Hosting Wiki

  • Django
  • Server Redundancy
  • Linux Containers
  • Google Cloud CDN
  • AMP
  • Bare Metal Server
  • Backup
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Linux
  • MongoDB
  • Joomla! Toolkit
  • Domain
  • WP Toolkit
  • WordPress
  • Hosting Control Panel
  • Plesk
  • SQL database
  • NoSQL Database
  • Web Server
  • Static DNS
  • DNS Server
  • DNS Forwarding
  • Reverse DNS
  • SSH
  • Colocation Hosting
  • Reseller Hosting
  • Cloud Hosting
  • VPS Hosting
  • Dedicated Hosting
  • Shared Hosting
  • Free Hosting
  • Managed Hosting
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family