Plesk

Unable to remove IP address: IP address cannot be removed because it is used by DNS zone of one or more domains

Symptoms

Cause

Database inconsistency - incorrect IP address is assigned to a DNS record.

Resolution

  1. Log in to Plesk.

  2. Go to Domains > example.com and check the actual IP assigned to the domain:

  3. Go to Domains > example.com > DNS Settings and assign the actual IP address to all records:

For one record

  1. Click on the required record.
  2. Alter the IP address field.
  3. Submit the changes by pressing OK.
  4. Confirm the changes again with the Update button on the DNS Settings screen.

For all the records at once

Click on the Apply DNS Template button.

For all the incorrect records via CLI

  1. Connect to the server via SSH.

  2. Create Plesk database backup.

  3. Access Plesk database.

  4. Update incorrect records with the correct IP address:

    # UPDATE dns_recs SET displayVal = '10.39.91.111' WHERE displayVal = '203.0.113.2';

    UPDATE dns_recs SET val = '10.39.91.111' WHERE val = '203.0.113.2';

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