Symptoms
-
Users are unable to list messages after logging in and MailEnable webmail shows "Please wait..." window infinitely
-
After entering mail access credentials webmail returns back to the login form
- Unable to create folders or delete emails in MailEnable
-
The following messages can be found in Windows Event Viewer > Windows Logs> Application:
General: (MailEnable Authentication TD Provider error: 0) An error occured when accessing the resource: "C:Program Files (x86)ParallelsPleskMail ServersPostoffices" as user "SERVERIME_ADMIN". The error reported was: (5) Access is denied.
Failed to serialise index: D:MailEnablePostofficesexample.comMAILROOTjohndoeInbox. A File Access error occurred when opening the file (was retried for 40 seconds). No data can be written.
Cause
Insufficient permissions for the IME_ADMIN
user on the %MAILENABLE_PATH%Postoffices
or %MAILENABLE_PATH%Config
folder.
Resolution
It is required to set correct permissions for the IME_ADMIN
. For that:
-
Log into the server via RDP.
-
Run
%MAILENABLE_PATH%BinMEInstaller.exe
utility -
Execute action "
1. Common Installation (File Permission)
"
OR
-
Execute the following command via the command line:
icacls "%MAILENABLE_PATH%Postoffices" /grant "IME_ADMIN:(OI)(CI)(F)" /t
icacls "%MAILENABLE_PATH%Config" /grant "IME_ADMIN:(OI)(CI)(F)" /t
-
Check any folder inside
%MAILENABLE_PATH%Postoffices
or%MAILENABLE_PATH%Config
for proper permissions by right-click > Properties > Security.If
IME_ADMIN
still does not haveFull Control
, right-click on the corresponding folder Properties > Security > Advanced > Replace all child object permission entries with inheritable permission entries from this object > Apply -
Restart
MailEnable Postoffice Connector
service:sc stop MEPOCS && sc start MEPOCS