Symptoms
-
Mail is not sent from the server.
-
Incoming emails do not reach mailboxes. No bounce messages are sent.
-
There are no error messages in MailEnable logs (
C:Program Files (x86)Mail
).
EnableLoggingSMTP -
When tracking an incoming email message using MailEnable Message Route Trace Utility (Windows Start > Mail Enable > Message Tracking), it reports the following message:
0EDA192C191E491F876A174B9DF97A9D.MAI seems to have been delivered to the postoffice connector, but there was no log entry on 9/29/2024 to indicate that it was delivered to any mailbox.
Cause
The outgoing mail queue in C:Program Files (x86)Mail EnableQueuesSMTPOutgoing
and/or
is too large (about 20 000 items or more). This prevents MailEnable from processing new messages.
C:Program Files (x86)Mail EnableQueuesSFOutgoing
Resolution
-
Connect to the Plesk server via RDP.
-
Open Plesk Services Monitor from Windows tray.
Note: if it is not there, start Plesk Services Monitor from Windows Start > All Programs > Plesk.
-
Select MailEnable services and click Stop:
-
Open folder
C:Program Files (x86)Mail EnableQueuesSMTPOutgoing
and check the amount of files there.If there are a lot of items (about 20 000 or more):
4.1. Go to upper folder
C:Program Files (x86)Mail EnableQueuesSMTP
.4.2. Rename the
folder to
OutgoingOutgoing_full
.4.3. Create a new folder with the name
Outgoing
. -
Open folder
C:Program Files (x86)Mail EnableQueuesSF
and check the amount of messages there.If there are a lot of items:
5.1. Go to previous folder
C:Program Files (x86)Mail EnableQueuesSF
.5.2. Rename the
folder to
OutgoingOutgoing_full
.5.3. Create a new folder with the name
Outgoing
. -
Open Plesk Services Monitor and start all MailEnable services back.
Note: To resend the deferred messages, move them from the
Outgoing_full
folder to the newly createdOutgoing
folder in groups of 1000 files and wait for them to be sent (the items will disappear from the folder).