Plesk

Issuing a Let’s Encrypt SSL certificate failed: the domain’s nameservers may be malfunctioning

Symptoms

Cause

Temporary issues with DNS resolution caused by network connectivity troubles on the side of the server provider. If external nameservers are used and the primary DNS zone for the domain is external, connectivity issues to them are a likely cause for the issue.

Alternatively, all DNS records have been removed from the DNS zone of the domain on the side of its primary DNS zone (regardless of whether it resides on the side of the plesk server or not).

Resolution

For the first scenario, you should wait for the network connectivity troubles to be resolved on the side of the server provider and make sure the domain is properly resolvable and attempt to reissue the certificate.

If the primary DNS zone for the domain resides on the side of Plesk and the DNS records for this domain have been removed entirely and you see no records while going to Plesk > Domains > Hosting & DNS > DNS, the recommendation is to reset the DNS zone by following these steps:

1. Log into Plesk

2. Go to Domains > Hosting & DNS > DNS

3. Press the Reset to Default button

4. Confirm the IP address details on the next screen and press OK

This action will recreate the necessary A and AAA DNS records

Additional information

How to check propagation of DNS records for a Plesk domain?

What is DNS? | How DNS works | Cloudflare

Adding and Modifying DNS Records | Managing DNS Records | Plesk Obsidian documentation

What is DNS propagation? | DigiCert FAQ

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