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Knowledge Base

A website is QUARANTINED in the Plesk WP Toolkit with no signs of malware

 
applications extensionscacheclihttpslinux

Symptoms

  • Plesk Obsidian running on a Linux-based operating system
  • The WP Toolkit in Plesk marks a website as QUARANTINED
  • The following messages could be found ion the /var/log/plesk/panel.log:

    ERR [extension/wp-toolkit] WP-CLI command has not finished working in 60 seconds, so it was terminated. Usually this means that there are problems with WordPress instance WordPress installation #39 ('https://www.example.com') itself, for example it could be infected with malware. Check the wp-config.php file of the instance for potential malware code.
    ERR [extension/wp-toolkit] Failed to reset cache for the instance #39, reason: Unable to finish running an operation on this site in 60 seconds. Operation was canceled. This is most likely caused by a server load spike, uncommon directives in wp-config.php, or a malware infection. Try running the operation again later. If this problem persists, make sure there are no customizations in wp-config.php that could slow down parsing this file, and consider checking the website for viruses and malware.

  • The WordPress core files: wp-config.php, wp-settings.php, index.php, /wp-includes/functions.php do not contain any signs of malware, infections or suspicious code.

Cause

In rare cases, the interaction of a certain WordPress website with the WP Toolkit in Plesk may be happening slower than usual due to a specific set of plugins and themes for WordPress used on the website. In such a situation, the WP Toolkit in Plesk may treat this unusually slow response from the website as caused by malicious code, which in turn would cause it to place the website in the quarantined category.

Resolution

If the website has been scanned for malware using the following article, and it is absolutely certain that it does not contain malicious code, you can resolve the issue by increasing the timeouts on the side of the WP Toolkit by following these steps:

1. Log into Plesk
2. Open the Plesk panel.ini by using the information in this article:

How to edit Plesk panel.ini – Plesk

3. Increase the timeout values for the WP Toolkit by adding the following entries at the bottom of the file:

[ext-wp-toolkit]
wpCliTimeoutHeavy = 1800
wpCliTimeoutMedium = 300
wpCliTimeoutRegular = 300
wpCliTimeoutRegularTimeout = 180
wpCliTimeoutMaintenanceTimeout = 180

4. Save the changes

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