Symptoms
Domain
example.comshows Plesk Default Page or Default Apache Page (Default Webserver Page), or "took too long to respond"Plesk server is behind NAT, configured with internal IP addresses.
Going to Tools & Settings > IP Addresses, the internal IP addresses don't have a public IP address assigned.
Domain example.com resolves to a public IP address:
# dig +short example.com
203.0.113.2In Linux, running tcpdump utility in Plesk server shows that domain's traffic goes to external IP 192.0.2.2 with the following command:
Note: IP 203.0.113.5 represents the public IP address where the website is requested from.
# tcpdump -n "dst port 80 and src host 203.0.113.5"
...
05:22:50.870868 IP 203.0.113.5.57486 > 192.0.2.2.http: Flags [F.], seq 1635309888, ack 2130394795, win 16425, length 0
...In Windows, Plesk may not be accessible:
This site can't be reached
Cause
Incorrect IP address mapping is configured in Plesk.
Resolution
Note: If Plesk is inaccessible, the same steps can be applied in Plesk for Windows via RDP
Map external IP address 203.0.113.2 as Public IP address in Tools & Settings > IP Addresses > 192.0.2.2 > OK:

Go to Domains > example.com > Web Hosting Access and ensure that the domain's IP address shows the domain's public IP address.
If the issue persists and the changes are not reflecting on the website, contact a network administrator to ensure that NAT translation for the domain is properly configured in the external firewall.