Plesk

Warning on the “Database Servers” page in Plesk: Unable to determine the TCP port number used by Microsoft SQL server

Symptoms

Cause

Microsoft SQL Server is not configured to use a static port.

Resolution

  1. Connect to the Plesk server via RDP.

  2. Go to Start > All Programs > Microsoft SQL Server XXXX > SQL Server XXXX Configuration Manager.

    Note: XXXX is a version of MS SQL Server from the error message.

  3. Expand SQL Server Network Configuration and click Protocols for MSSQLSERVERXXXX.

  4. Double-click on TCP/IP:

    4.1. On the Protocol tab, make sure that the TCP/IP protocol is Enabled.

    4.2. Switch to the IP Addresses tab and scroll down to the IPAll section.

    4.3. Specify default MS SQL port number 1433 (or a custom port number if 1433 is already used by another MS SQL Server instance) in the TCP Port field

    Note: The specified MS SQL port must be opened in firewall.

    4.4. Click OK.

  5. Go to SQL Server Configuration Manager (Local) > SQL Server Services,

  6. Right-click on SQL Server (MSSQLSERVERXXXX) and click Restart to apply the changes.

  7. Log in to Plesk.

  8. Go to Tools & Settings > Database Servers > .MSSQLSERVERXXXX > Settings and click OK to sync new settings with Plesk.

 

Video Instructions

 

Additional Information

If you use Microsoft SQL Server Management Studio to connect to an SQL Server with a custom port, specify this port after a comma: 203.0.113.2,1433.