Plesk

Unable to remove WordPress instance via Applications: Permission denied

Symptoms

Cause

This issue is reported as bug ID EXTWPTOOLK-3043 which will be fixed in future updates.

Resolution

Until the issue is resolved, the following workaround can be applied:

When the instance is shown in WP Toolkit

  1. Log into Plesk.
  2. Remove instance via WP Toolkit

When the instance is not shown in WP Toolkit

  1. Connect to the server via SSH

  2. Run the following command to find the ID of the instance:

    # plesk ext wp-toolkit --list |grep example.com |awk {'print $1"t"$7'}
    365 http://example.com/old

  3. Remove the instance with the following command. Use the ID from step 2. as value after -instance-id:

    # plesk ext wp-toolkit --detach -instance-id 365

  4. Remove the WordPress related files of the removed instance in the file system