Symptoms
On a Plesk for Windows server, logging in to Plesk fails:
Error message or request description : Unable to connect to pipe .pipeP_7da1332a-fe05-4176-91f2-4c4457fb71f0at (Con::ClientOverlappedPipe::create line 509)at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 327)at Unable to get administrator password: <Password has been wiped out for security reasons> line 205)
ERROR: Exception: Access is denied. (Error code 5) at Unable to connect to pipe .pipeP_36a625a6-260f-44af-b844-3beee654dbd6<br> at (Con::ClientOverlappedPipe::create line 503)<br> at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 337)<br> at Unable to get administrator password:(zif_get_admin_password line 206) (Helper.php:68)0: Helper.php:68get_admin_password()...AutoPrepend->run()9: auth.php:690
Attempt to upgrade Plesk fails with the same error.
Cause
Plesk Management Service is stuck, not started or not available.
Resolution
Connect to the server using RDP.
Restart the Plesk Management Service using the Plesk Services Monitor (Plesk icon in the tray menu):
Kill the process plesksrv.exe in the Task Manager and restart the service along with PopPass service:
Run
%plesk_dir%adminbinreconfigurator.exe> Repair Plesk Installation > Plesk services: