Symptoms
- On a CloudLinux server, the Plesk GUI is not accessible with a 500 Internal Server Error showing up in the browser
- The following error can be found in
/var/log/plesk/panel.log
:ERROR: PleskExceptionDatabase
DB query failed: SQLSTATE[HY000]: General error: 1021 Disk full (/var/tmp/#sql_3b95_1); waiting for someone to free some space..., <...> - Running the
df -h
command shows that there is no free space on the disk that is used for the Plesk installation - The
/var/www/vhosts/system/example.com/logs/php-fpm_error.log
of at least one domain on the server gets populated with entries that are similar to the following constantly:
WARNING: [pool example.com] child 15856 said into stderr: "ERROR: [pool example.com] CageFS jail error Failed to set permissions to /var/www/vhosts/example.com/.cagefs/tmp (Operation not permitted): Operation not permitted (1)"
Cause
Incorrect permissions on the /var/www/vhosts/example.com/.cagefs/tmp
file are creating an error loop.
Errors are constantly written to /var/www/vhosts/system/example.com/logs/php-fpm_error.log
and this fills up all of the remaining disk space on the server in a relatively short period of time.
Resolution
1. Connect to the server via SSH
2. Set the correct permissions for the file in the error message, so that the log file stops being populated with errors (make sure to replace the sysuser with the actual system user name for the Subscription and example.com with the required domain name):
# chown sysuser:psacln /var/www/vhosts/example.com/.cagefs/tmp
3. Empty the large log file for the website:
# echo > /var/www/vhosts/system/example.com/php-fpm_error.log
Such log entries should no longer be generated constantly after this has been done.