Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • WP Guardian
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • WP Guardian
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • WP Guardian
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • WP Guardian
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Plesk Migration error: Failed to check SSH connection to the source server ‘source’

 
backup restore migrationfail2banfirewalliplinux

Applicable to:

  • Plesk for Linux

Symptoms

  • A Plesk migration (Tools & Settings > Migration & Transfer Manager) is currently stuck at "Check connections" phase.

  • The migration info.log file on the target server shows the following error:

    # less /opt/psa/var/modules/panel-migrator/sessions/20230105213105/info.log
    [2023-01-05 21:31:07][ERROR] Unable to execute command because another migration is in progress.
    [2023-01-06 15:01:37][INFO] START: Check connections
    [2023-01-06 15:03:47][ERROR] Unable to connect to '203.0.113.2' by SSH: [Errno 110] Connection timed out. Retrying in 10 seconds
    [2023-01-06 15:06:07][ERROR] Unable to connect to '203.0.113.2' by SSH: [Errno 110] Connection timed out. Retrying in 10 seconds
    [2023-01-06 15:08:26][ERROR] Unable to connect to '203.0.113.2' by SSH: [Errno 110] Connection timed out. Retrying in 10 seconds
    [2023-01-06 15:10:45][ERROR] Unable to connect to '203.0.113.2' by SSH: [Errno 110] Connection timed out. Retrying in 10 seconds
    [2023-01-06 15:13:05][ERROR] Failed to check SSH connection to the source server 'source' (203.0.113.2): Unable to connect to '203.0.113.2' by SSH: [Errno 110] Connection timed out.
    Ensure that the server is up and there are no firewall rules that may block SSH connections to the server, then restart migration.

  • An SSH manual connection from the target to the does not work:

    # root@plesk-server:~# ssh -v [email protected] -p22
    OpenSSH_8.2p1 Ubuntu-4ubuntu0.5, OpenSSL 1.1.1f 31 Mar 2020
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
    debug1: /etc/ssh/ssh_config line 21: Applying options for *
    debug1: Connecting to 203.0.113.2 [203.0.113.2] port 22.

  • Telnet from the target also does not work:

    # root@plesk-server:~# telnet 203.0.113.2 22
    Trying 203.0.113.2...
    telnet: Unable to connect to remote host: Connection timed out

  • Target IP address is not blocked by Fail2ban or is in the allowlist (whitelist).

  • Target IP is not blocked on source firewall, and SSH connections are allowed.

Cause

Network connection issue between servers

Resolution

Contact the network administrator

Read the full article
Related Posts

How to Check Open Ports in Linux (Simple Commands & Tools)

Read More »

Linux Logs Explained

Read More »

How to Use Fail2ban to Secure Your Linux Server (CentOS, Ubuntu, Debian, Fedora, and Plesk)

Read More »
Knowledge Base

Fail2Ban fails to start on Plesk for Linux server: Could not enable jails, Failed during configuration: Have not found any log file for ssh jail

Read More »

On Plesk for Linux server, deny rules set up in Plesk Firewall do not block connections to Docker container

Read More »

Unable to connect to a Plesk server via FTP: Server sent passive reply with unroutable address. Using server address instead.

Read More »

How to allow connections to a port from specific IP addresses only in Plesk

Read More »

Hosting Wiki

  • Server Redundancy
  • Linux Containers
  • AMP
  • Bare Metal Server
  • Backup
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Linux
  • JavaScript
  • Plesk
  • Web Server
  • DNS Server
  • IPv6
  • IPv4
  • SIP
  • SSH
  • UDP/IP
  • Firewall
  • Network Bandwidth
  • TCP/IP
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family